Ir para conteúdo principal

VivaWallet: Confirmação de Pagamento em Falta

Mitigue o impacto dos tempos limite de pagamento implementando um webhook simples a partir da sua conta de comerciante VivaWallet.

Atualizado esta semana

Problema

Os tempos limite de pagamento de viagens durante reservas online podem ser um problema significativo, afetando tanto a experiência do cliente como as operações comerciais. Essas interrupções podem desencorajar os clientes a concluir a compra, levando-os a abandonar a reserva e a criar um duplicado antes da confirmação do pagamento.


Causa

As causas dos tempos limite de pagamento podem variar, incluindo ligações lentas à internet, problemas técnicos com o gateway de pagamento ou simplesmente o cliente ter fechado a aba do navegador.


Solução

Em vez de depender da cadeia de comunicação por defeito entre o gateway de pagamento e o web checkout, pode configurar um webhook para acionar uma confirmação de pagamento da VivaWallet para a Ventrata, independentemente da velocidade da internet do cliente.

  1. Inicie sessão na sua conta VivaWallet.

  2. Selecione o seu perfil ou conta de comerciante.

  3. Vá para Settings (Definições) > API Access (Acesso API).

  4. Na aba General (Geral), copie o seu Merchant ID (ID do comerciante).

  5. Mude para a aba Webhooks .

  6. Pressione o botão Create Webhook (Criar webhook).

  7. Introduza o seguinte link no campo 'URL': https://api.ventrata.com/vivawallet/notify/{your-merchantID}


    📗 DICA

    Substitua {merchantID} pelo seu Merchant ID (ID do comerciante).


  8. Assinale a caixa 'Ativo'.

  9. Selecione o tipo de evento 'Transaction Payment Created'.

  10. Pressione o botão Save (Guardar).

  11. O novo webhook aparece na aba Webhooks.

Isto respondeu à sua pergunta?